VC1Qcs problem

Home Forums Ask Ted VC1Qcs problem

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • #31070


    I’m a proud owner of a VC1Qcs which I really love, bought it new 22 years ago and it’s still my favorite compressor. But lately I have a problem with it.

    It works just fine using the line input but using the XLR doesn’t.

    It works for a couple of seconds and then stops. Switching it off/on gets it started again, but only for a few seconds. Read about another case here where a capacitor was the problem . Could this be the case here too, if so which one could it be?

    Must say I’m impressed by the way you take care of owners of your gear!

    Thanks in advance!

    / Gunnar from sweden

    You must be logged in to view attached files.

    Problem solved  😁

    Thanks Ted!

    I followed your advice in the other thread about using WD40 and now it works as new again. Wow!

    I’m a happy dude again.

    Thank you, thank you, thank you!

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.