Help Please!! Humming problem with my Joe Meek VC3 v2

  1. Home
  2. Forums
  3. Ask Ted
  4. Help Please!! Humming problem with my Joe Meek VC3 v2

Home Forums Ask Ted Help Please!! Humming problem with my Joe Meek VC3 v2

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #15259
    mikewalker
    Participant

    Hello Ted,

    I Have a problem with my Joe Meek VC3 v2. A strange bassy humming sound has cropped up today :( I think its a power problem it was working fine and has done for years (with the original PSU) but today its decided to throw a wobbler!

    The strange hum starts right prom power up and fluctuates when Phantom power is turned on and also when the compressor and exciter activate. If you could suggest anything that may be wrong with the VC3 or if you could suggest someone who could repair the unit for me that would be fantastic.

    thanks

    Michael

    heres a video to show the problem….

    https://www.youtube.com/watch?v=AOecvKGn15w

    #15733
    psmworld
    Participant

    1. faulty power supply

    2. corrosion or broken connection on one of the inputs

    3. ground got loose inside (is there a ground connected to the chassis?)

    #15734
    mikewalker
    Participant

    Hi thanks for getting back to me, I’ve checked all the suggestions above but no luck power supply is fine, inputs are fine and ground is connected :(

    could anyone recommend a repair shop please?

    Cheers

    Michael

    And Happy Christmas to you all too :)

    #15735
    Ted Fletcher
    Keymaster

    Hmmm…. I think you will find that this problem will go away on its own!!!!! :(

    I would put money on it that the problem is low mains voltage. During periods of high demand, the voltage of the mains can drop up to 10% and this is enough to prevent the voltage regulators in the VC3 operating properly. During the design stage it’s always a compromise between overheating of the regulators or possible hum problems…. if you live in an area where the mains voltage fluctuates, then this can be a common problem!

    If I’m wrong, please let me know and I will fix your VC3 with pleasure, but I suspect that this is the problem! :)

    #15736
    mikewalker
    Participant

    Hello Ted,

    Happy New year to you and thanks for getting back to me. Well I took your advice and tried the VC3 with a power conditioner but unfortunately the problem hasnt gone away :( Could you let me know how I can arrange to have the unit repaired please, its one of my favourite preamps and I’m missing it in the studio.

    Thanks very much

    Michael

    #15737
    Ted Fletcher
    Keymaster

    Just send it to me, Ted Fletcher, The Sound House, Hunsdon Road, Torquay TQ1 1QB. and I will fix it.

    The cost is £30 plus the cost of return (£4.50 for the UK) unless I need to buy expensive components…. which is very unlikely for a VC3.

    Please make sure you enclose a note with your address and email…… (I have some equipment here that was sent without a note, and I can’t contact the owner!)

    #15738
    mikewalker
    Participant

    HI Ted, thanks I will post the VC3 this week and enclose a letter for you. how do i go about paying you? would you like or a cheque or bank transfer? if you would like to contact me via email with your details thats fine: michaelwalker76@gmail.com

    Thanks Again,

    Michael

    #15739
    Ted Fletcher
    Keymaster

    Payment by paypal is fine….. will contact you by email. :)

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.
Menu